Diesen Thread durchsuchen:   1 Anonyme Benutzer



BottomBottom  Vorheriges Thema Vorheriges Thema  Nächstes Thema Nächstes Thema   Zum Post anmelden

(1) 2 »


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#15
"myXOOPs"-Neuling
"myXOOPs"-Neuling


Siehe Benutzerinformationen
Nach den eingetragenen Versionsangaben in der xoops_version.php setzen alle Versionen ab RC10 Xoops 2.5.8 voraus.

Ich werde kommende Woche mal eine Experiment-und Test-Installation aufziehen und schauen, ob dort die RC8 fehlerfrei läuft.
Falls ja, muss ja irgendwo ein Unterschied bestehen irgendwo.

Sind die beschriebenen Tücken dort reproduzierbar, werde ich schauen, ob eine spätere NewBB-Version hier besser funktioniert.

Sofern dann Unterschiede in der MySQL-Datenbank bestehen, kann ich diese vielleicht manuell anpassen...

Um zu verstehen, was in der viewforum.php geschehen soll, geschieht und nicht geschieht, bräuchte ich Kenntnisse über Xoops Interna selbst, das ist derzeit etwas zu hoch für mich...

Aber ich werd mich da auch nochmal bei xoops.org melden.

Beste Grüße
Andy

Gepostet am:11.11.2016
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#14
Co-Administrator
Co-Administrator


Siehe Benutzerinformationen
Hi Andy

bevor du dich weiter mit der Kombination xoops 2.5.7.2 und newbb 4.33 rc13 befasst, würde ich mal auf xoops.org ein Posting absetzen, ob 4.33 rc13 wirklich mit xoops 2.5.7.2 kompatibel ist. Vielleicht kommt ja das Problem des Nichtfunktionierens davon.

Gepostet am:11.11.2016
EDV = Epoche der Verzweiflung
 Top  Bericht


Advertisement


Hier könnten Sie Ihre Anzeige aufgeben!
Bitte kontaktieren Sie uns, um mehr darüber zu erfahren.
 Top 


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#13
"myXOOPs"-Neuling
"myXOOPs"-Neuling


Siehe Benutzerinformationen
Moin Goffy,

ich hab das 2.5.7.1 von hier installiert.
Bin extra nochmal die Checksumme durchgegangen, weil ich auf nem Werbeserver Probleme hatte.

Stimmte aber alles.
Nach dem zweiten Check hab ich dann installiert.

Was ich versuchen kann ist, das Upgrade auf 2.5.7.2 aufzuspielen und dann nochmal ein Update vom NewBB RC13b zu versuchen.

Bei, 2.5.7.1 bekam ich die Meldung, dass 2.5.8 benötigt würde.

Die Cache-Problematik bestand nur bei NewBB RC8. Mit RC13b funktioniert die Darstellung soweit gut, bis auf die oben beschriebenen Kuriositäten.

Weshalb nur beim RC8 bei mir das Abtrennen von Beiträgen in Teilen nicht richtig funktioniert, bei allen anderen Versionen gar nicht, verwundert mich.

Da hier und bei xoops.org ja sonst keine solchen Phänomene berichtet wurden, scheint es sich um eine recht individuelle Erscheinung zu handeln...

Ich werde mal ein Upgrade auf 2.5.7.2 in der kommenden Woche durchführen und dann schauen, ob ich das ein Update auf RC13b durchführen kann/darf und was das dann bewirkt...

Danke Dir für die Hilfe schon mal bis hierher!

Beste Grüße
Andy

Gepostet am:10.11.2016
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#12
Co-Administrator
Co-Administrator


Siehe Benutzerinformationen
Hi Andy

ich bin ja leider betreffend newbb nicht so fit.
Ich habe mal testweise newbb 4.33 RC13b auf xoops 2.5.7.2 installiert.
Bis auf das Warning mysqli_get_server_info() scheint alles zu funktionieren.
Und bei Dir kommen anscheinend alle möglichen ominösen Fehler.

Es hat ja wegen des Cacheproplems das Update von newbb nicht richtig funktioniert. Kann es sein, dass dein Xoops-Core auch nicht vollständig upgedated wurde?
Arbeitest Du mit einem Altsystem, das du auf 2.5.7 upgedatet hast oder hast du ein neues 2.5.7 installiert?

Gepostet am:10.11.2016
EDV = Epoche der Verzweiflung
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#11
"myXOOPs"-Neuling
"myXOOPs"-Neuling


Siehe Benutzerinformationen
Ich hab heute mal alles (Un)Mögliche ausgetestet:
RC9 und RC10 aufgespielt und auch RC reaktiviert.
Keine Version funktioniert komplett bei mir. Liegt das an meinem System?

RC9 zeigt bei normalen Nutzern keine Beiträge in einem Thema an ("WhiteForum"), dafür wird die IP korrekt gespeichert. Moderation: Trennen von Beiträgen bleibt ohne Resultat.

RC10 speichert die IP wieder fehlerhaft, Abtrennen von Beiträgen in der Moderation bleibt ergebnislos.

RC8 wie beschrieben: Bei der Anzeige eines Forums: "WhiteForum".

Spaßeshalber die viewforum.php aus RC9 ins RC8 eingespielt: "WhiteScreen" (wär ja auch zu schön gewesen ).

Nun läuft das NewBB woeder als Zwidder aus installiertem RC8 und den Installationsdateien von RC13b. Moderation (Teilen von Beiträgen) bleibt auch hier egebnislos: Alles bleibt, wie es war.

Nun werd ich mir mal die viewforum.php vom RC8 anschauen. Wäre ja nett, wenn ich herausfinden würde, weshalb das nicht dunktioniert.

Gruß
Andy

Gepostet am:10.11.2016
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#10
"myXOOPs"-Neuling
"myXOOPs"-Neuling


Siehe Benutzerinformationen
Fehlerlog wäre nicht verkehrt, gell?

Debug meldet:
Zitat:
Hinweis: Use of undefined constant _MI_PAGENAV_NUMBER - assumed '_MI_PAGENAV_NUMBER' in Datei /modules/newbb/xoops_version.php Zeile 318
Hinweis: Use of undefined constant _MI_PAGENAV_IMAGE - assumed '_MI_PAGENAV_IMAGE' in Datei /modules/newbb/xoops_version.php Zeile 319
Warnung: mysqli_get_server_info() expects parameter 1 to be mysqli, resource given in Datei /modules/newbb/class/online.php Zeile 249

Gepostet am:09.11.2016
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#9
"myXOOPs"-Neuling
"myXOOPs"-Neuling


Siehe Benutzerinformationen

Hi Goffy,

also der Frontend-Hausgebrauch für normale Nutzer ist soweit ok.
Eingeschränkter sind weiterführende Funktionen:

  • Speichern der IP-Adresse: Es werden nur die linken 4 oder 5 Stellen abgespeichert.
  • Abtrennen einzelner Beiträge in einem Thema bleibt ohne Effekt: Der Beitrag befindet sich weiterhin im Thema und wurde auch nich als separates Thema im Forum abgelegt.
  • Das Abtrennen mehrerer Beiträge funktionierte bei RC8 nur bei zwei aufeinander folgenden Beiträgen. Mit den verwendeten RC13b-Dateien passiert nun auch dabei nichts mehr

Ob es in der Administration Veränderungen gibt, habe ich noch nicht getestet.

Auf jeden Fall beinhalten die RC13b-Quellen fehlende Dateien aus "meiner" RC8-Version.

War jetzt am überlegen - falls die kompletten Quellen von RC8 nicht mehr auftreibbar sein sollten - obe ich beide Modulverzeichnisse abgleiche und so vielleicht auf "vermisste" Dateien stoße...

Wirklich glücklich bin ich mit diesem "Rumgefriemel" nicht, auch wenn es oberflächlich ersteinmal läuft.

Weißt Du, wo ich vielleicht noch an deutsche Sprachpakete und an ein vollständiges RC8 (der eben das Letzte, welches für 2.5.7 geschrieben wurde) rankommen kann?

Rest im anderen Thema.

Gruß

Andy


Gepostet am:09.11.2016
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#8
Co-Administrator
Co-Administrator


Siehe Benutzerinformationen
hi

http://www.myxoops.org/modules/newbb/viewtopic.php?post_id=73558
Zitat:
Oder gibt es eine Möglichkeit, das bei mir installierte newbb auch in der Moderation komplett wieder herzustellen?

Ich versteh nicht ganz: läuft dein Forum jetzt oder nicht?

Gepostet am:09.11.2016
EDV = Epoche der Verzweiflung
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#7
"myXOOPs"-Neuling
"myXOOPs"-Neuling


Siehe Benutzerinformationen
Zwischenerfolg.

Caces geleert.

DB-Backup
newbb 4.33 RC8 deinstalliert, Modulverzeichus /modules/newbb umbenannt
newbb 4.33 RC7 aufgespielt --> /modules/newbb --> installiert
DB-Backup aufgespielt --> nur erste Kategorie ansteuerbar.
Update 4.33 RC7 --> RC8 --> Wie oben beschriebene Situation
Modulverzeichus /modules/newbb umbenannt
newbb 4.33 RC13b aufgespielt --> /modules/newbb Aktualisierung wegen Xoops-Version nicht möglich.
Mit den vorhandenen Dateien laufen nun alle Funktionen.
Deutsche Sprachdateien aus RC8 aufgespielt.

Welche Dateien da jetzt gefehlt haben? Keine Ahnung.
klingt mir nicht ach einem gewollten und gesollten Weg, aber wenn die Quelle offenbar defekt ist...

Gepostet am:07.11.2016
 Top  Bericht


Aw: Foren nicht mehr wählbar nach Cache-Löschung
#6
"myXOOPs"-Neuling
"myXOOPs"-Neuling


Siehe Benutzerinformationen
Hi Goffy,

bin jetzt frei am experimentieren.

Der Link für die Sprachdateien mündet in einer Fehlerseite: 404 - Page not found

Bei Sprachumstellung bleibt nur noch der Smarty-Fehler über.

Gepostet am:07.11.2016
 Top  Bericht




(1) 2 »




[Erweiterte Suche]


Design by: XOOPS UI/UX Team