MyXoops Forum

Aw: Mysql Importprobleme [Entwicklung allgemein] - myXOOPS German Support

Goffy

Co-Administrator
Gepostet am:07.01.2019 13:25
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 563
Since: 14.10.2004
#3

Aw: Mysql Importprobleme

hi

am Webserver hab ich 4.8.3
beim lokalen Server (Wamp) habe ich 5.7.11

ich arbeite auf beiden Systemen mit phpMyAdmin
EDV = Epoche der Verzweiflung

alfred

Administrator
Gepostet am:05.01.2019 11:16
alfred
alfred Offline (Show more)
Administrator
Posts: 7607
Since: 06.12.2004
#2

Aw: Mysql Importprobleme

im Normalfall sollte das keine Probleme machen.
Wie bzw. mit was exportierst du die Daten und mit was fügst du die wieder ein?
z.B. phpmyAdmin maskiert die Daten so das es eigentlich keine Probleme geben sollte.

Zum Datum kannst du vor dem Import eingeben:
SET sql_mode = '';

Advertisement

Gepostet am:0
Advertisement (Show more)
Posts: 0
Since: 0


Hier könnten Sie Ihre Anzeige aufgeben!
Bitte kontaktieren Sie uns, um mehr darüber zu erfahren.

Goffy

Co-Administrator
Gepostet am:04.01.2019 17:10
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 563
Since: 14.10.2004
#1

Mysql Importprobleme

Hi zusammen

ich hab immer wieder mal Probleme, wenn ich Tabellen vom Webserver exportiere und dann auf meinen lokalen System wieder importieren möchte.
Beispiele:
- Singlequotes: in eine Textfeld kommt Zitat:
can\'t
vor => Fehler
- Import in user-Tabelle: #1292 - Incorrect datetime value: '0000-00-00 00:00:00' for column 'updated' at row 2

was muss ich da umstellen?
EDV = Epoche der Verzweiflung
Diesen Thread durchsuchen:  1 Anonyme Benutzer