MyXoops Forum

Forum - myXOOPS German Support

 

Nach Bearbeiten der Templates werden Änderungen nicht übernommen

Betreff: Nach Bearbeiten der Templates werden Änderungen nicht übernommen
von migoe am 20.06.2015 18:44:16

Grüß Gott zusammen,

ich bin zwar schon seit 2003 mit Xoops unterwegs, habe aber heute ein Problem, mit dem ich selber nicht mehr klar komme und hoffe, hier findet sich jemand, der eine Lösung weiß:

Ich überarbeite gerade die Templates von einige Modulen und habe das Problem, dass ich zwar verschiedene Möglichkeiten und Stellen habe, um Templates zu ändern, aber die Änderungen werden nicht angenommen/angezeigt.

Ein Beispiel:

Das Template des Forenmoduls newbb (Version 4.3) für die index.html habe ich zuerst im Template-Manager des Adminbereichs bearbeitet und das Diskettensymbol angeklickt. Danach kam die Meldung "Speichern" sonst nichts. Bei der Aktualisierung der Seite wurden die Änderungen nicht angezeigt.

Ich hab es dann über die Datein auf dem Server versucht

-> zuerst die index.html im Verzeichnis /themes/-meinTheme-/modules/newbb/
-> Die Datei ließ sich nicht zurück auf den Server übertragen, wegen Schreibrechten
-> Ich habe sie dann auf dem Server entfernt und vom Rechner übertragen. Resultat war...
-> KEINE WIRKUNG

-> danach die index.html im Verzeichnis /modules/newbb/templates/
-> KEINE WIRKUNG

So geht es mir auch mit den Templates von /modules/AMS/ und modules/news/

Ich habe ja schon gelesen, dass es seit Xoops 2.5 eine andere Vorgehensweise bei den Templates gibt, aber leider habe ich keine Lösung für die Probleme, die andere scheinbar auch haben, finden können.

Gibt es einen Trick, der noch nicht verraten wurde?

Mit "alten" Modulen bei denen direkt in den php-Dateien Änderungen vorgenommen werden müssen, klappt die Übernahme sofort, was auch nachvollziehbar ist. Leider nicht bei den Templates.

Leider kann ich nicht sagen, ob ich vor dem Update auf die Version 2.5.6 (die läuft nämlich bei mir) im Template-Manager das Templateset auf "default" geändert habe und es deshalb nicht klappt. Sicher ist, dass ich in den Einstellungen die Option "Templates auf Änderungen prüfen?" auf "JA" steht.

migoe

P.S. Direkt in der Datenbank habe ich die Templates auch gefunden und die Änderungen eingetragen und gespeichert - trotzdem KEINE WIRKUNG!