MyXoops Forum

Forum - myXOOPS German Support

 

Address Modul mit Hack - https Seite... - Google Maps wird nicht dargestellt

Betreff: Address Modul mit Hack - https Seite... - Google Maps wird nicht dargestellt
von tohm am 19.03.2020 19:56:27

Wie schon geschrieben funktioniert das meiste... Mein Google Maps leider noch nicht...

Auf dem lokalen Webserver in der http Version funktioniert Maps problemlos.

Habe online aber SSL aktiviert und läuft soweit auch alles mit https Ausnahme: Google Maps. Siehe:
https://www.brunnen-trinkwasser.de/mod ... resses/cat_view.php?cid=1
Es kommt immer im Quelltext: src="http://maps.google...... ohne "s" bei http...

Ich habe jede Datei im Modul Address jetzt schon 2 Mal geöffnet und geprüft...

Geändert habe ich bereits manuell auf https:
google_maps_popup.php
templates:
addresses_viewcat.html
addresses_singleaddress.html
addresses_google_maps.html

Ferner habe ich im Root Verzeichnis bei Xoops Data - smarty_cache, smarty_compile und xoops_cache alle Dateien gelöscht außer der index Datei.

Am Browser habe ich den Cache gelöscht.

In Xoops habe ich die Template Änderungsprüfung in den Grundeinstellungen mal eingeschaltet und mal abgeschaltet.

TROTZDEM kommt src="http://maps.google...... immer ohne "s"... Das ist zum Mäuse melken.

Vom Hoster ist für SSL folgender Eintrag in der .htaccess:
RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} =http [OR]
RewriteCond %{HTTP:X-Forwarded-Proto} =""
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Jemand eine Idee wo der Pfad noch eingetragen ist bzw. was ich falsch mache?!

Danke

Thomas