MyXoops Forum

Forum - All Posts - myXOOPS German Support

Forum Index


Board-Index » All Posts

BottomBottom



WDC

"myXOOPs"-Profi
Gepostet am:09.04.2021 21:31
WDC
WDC Offline (Show more)
"myXOOPs"-Profi
Posts: 635
Since: 27.06.2004
#11

xsitemap and SEO URLS

Servus,

Ich habe jetzt teils SEO URLS am laufen. Aber wie bringe ich xsitemap bei, diese zu nutzen?

Danke


WDC

"myXOOPs"-Profi
Gepostet am:09.04.2021 17:27
WDC
WDC Offline (Show more)
"myXOOPs"-Profi
Posts: 635
Since: 27.06.2004
#12

Aw: xoRewriteModulea - Simplified, Short URLs?

Da mir das keine ruhe gelassen hat, habe ich mal noch ein wenig getüftelt.

Ich habe jetzt in den php Dateien die vorhandene Möglichkeit genutzt, in der URL Zeichen zu ändern. Es bleiben zwar alle Sprachen in der URL vorhanden, aber sieht zumindest ok aus, wie es jetzt ist.

Ich würde hier gerne aber noch alle Umlaute und Sonderzeichen, direkt mit umwandeln lassen, utf8 nach ASCII

Sodas aus

https://kenner-mask.com/screenshots/-de-Der-tödliche-Meteor-en-The-Deathstone-fr-Un-précieux-météor-/cat,2,0,1350,0,list.html

wird

https://kenner-mask.com/screenshots/-d ... r-Un-precieux-meteor-/cat,2,0,1350,0,list.html

An der Stelle nehme ich die Änderungen vor, kann das da mit eingebaut werden?

public function getURL($uid$num$pos$view)
    {
        
$helper Helper::getInstance();
        
$moduleDirName basename(dirname(__DIR__));
        
/** @var XoopsModuleHandler $moduleHandler */
        
$moduleHandler xoops_getHandler('module');
        
/** @var XoopsConfigHandler $configHandler */
        
$configHandler xoops_getHandler('config');
        if (!isset(
$GLOBALS['screenshotsModule'])) {
            
$GLOBALS['screenshotsModule'] = $moduleHandler->getByDirname($moduleDirName);
        }
//        if (!isset($GLOBALS['screenshotsModuleConfig'])) {
//            $GLOBALS['screenshotsModuleConfig'] = $configHandler->getConfigList($GLOBALS['screenshotsModule']->getVar('mid'));
//        }
        
if ($helper->getConfig('htaccess')) {
            return 
XOOPS_URL '/' $helper->getConfig('baseurl') . '/' str_replace(
                    [
                        
'_',
                        
' ',
                        
')',
                        
'(',
                        
'&',
                        
'#',
                        
'[/de]',
                        
'[/en]',
                        
'[/fr]',
                        
'[',
                        
']',
                        
'--',
                    ],
                    
'-',

                    
$this->getVar('title')
                ) . 
'/cat,' $this->getVar('cid') . ',' $uid ',' $num ',' $pos ',' $view $helper->getConfig('endofurl');
        }

        return 
Helper::getInstance()->url() . 'viewcat.php?cid=' $this->getVar('cid') . '&uid=' $uid '&num=' $num '&pos=' $pos '&view=' $view;
    }


trucker2006

Dokuschreiber
Gepostet am:07.04.2021 20:09
trucker2006
trucker2006 Offline (Show more)
Dokuschreiber
Posts: 31
Since: 23.01.2010
#13

Aw: XOOPS 2.6.0 pre-Alpha 3 Installation Video

So ich habe es auch geschafft,da bei 2 Sachen im Video man sehr genau hinschauen muss.
Zum ersten war mein Fehler:
Der Pfad Composer stimmte nicht.Man kann ihn aber anpassen über die Systemsteuerung.Dazu gibt es genug Beschreibungen im Netz.
Der 2.Fehler war:
Im Video der Pfad von Xoops und es fehlte die composer.json.dist im Verzeichnis die aber im Core liegt.Htdocs liegt ebenfalls darunter.Die Lösung dazu composer.json.dist umbenennen in composer.json.Dann läuft die Installation ohne Probleme und auch in der Zeit.Danke nochmal!!
Dieser Beitrag kann geschlossen werden


Goffy

Co-Administrator
Gepostet am:07.04.2021 14:39
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 758
Since: 14.10.2004
#14

Aw: wggallery mit xoops 2.5.11 beta

Was sagt der Systemtest von wgGallery?

EDV = Epoche der Verzweiflung


Goffy

Co-Administrator
Gepostet am:07.04.2021 14:29
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 758
Since: 14.10.2004
#15

Aw: wggallery mit xoops 2.5.11 beta

welche PHP Version verwendest du?
EDV = Epoche der Verzweiflung


trucker2006

Dokuschreiber
Gepostet am:06.04.2021 20:05
trucker2006
trucker2006 Offline (Show more)
Dokuschreiber
Posts: 31
Since: 23.01.2010
#16

Aw: wggallery mit xoops 2.5.11 beta

Nein ich habe das upload Problem nur bei Xoops 2.5.11 nicht bei 2.5.10 da geht es problemlos.Ich spiel es mir aber nochmal intern auf und suche mal.Die Bilder sind zwar recht groß überschreiten aber nicht die upload Größe.Ich habe die gleichen bei 2.5.10 auch drin und es geht.Ganz so klar ist mir das noch nicht.Sollte ich etwas finden berichte ich hier.


trucker2006

Dokuschreiber
Gepostet am:06.04.2021 12:19
trucker2006
trucker2006 Offline (Show more)
Dokuschreiber
Posts: 31
Since: 23.01.2010
#17

Aw: XOOPS 2.6.0 pre-Alpha 3 Installation Video

Hi wertes Team!
Habe mal das Video nachvollzogen und es so gemacht.Er bleibt bei mir leider am Punkt stehen,wo die secure.php gefragt ist.Hatte mal die Suche bemüht anscheinend muss man die aus dem extra Ordner eventuell einspielen.Vielleicht weiss einer Rat dazu!
Ansonsten ich bin ohne Kenntnisse reingegangen,was Composer anbelangt muss aber sagen Zeit und Aufwand stimmt bislang.Hut ab!!


Goffy

Co-Administrator
Gepostet am:05.04.2021 10:18
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 758
Since: 14.10.2004
#18

Aw: wggallery mit xoops 2.5.11 beta

Hi

ich hab die wgGallery bereits auf mehreren Seiten laufen und mir ist kein Problem wegen Upload bekannt.

Tritt das Problem nur bei einem bestimmten Bild auf?
Ist es immer das dritte, unabhängig davon welche Bilder du hochladen möchtest?
Tritt das Problem nur beim Upload mit Handy auf oder auch auf anderen Geäten (Laptop usw.)
Verwendest du ein Bootstrap-Theme?
EDV = Epoche der Verzweiflung


trucker2006

Dokuschreiber
Gepostet am:05.04.2021 00:02
trucker2006
trucker2006 Offline (Show more)
Dokuschreiber
Posts: 31
Since: 23.01.2010
#19

wggallery mit xoops 2.5.11 beta

Hallo Freunde!

Ich habe versucht mal mit der derzeitigen xoops 2.5.11 beta zusammen die wggallery zu nutzen.Es läuft alles ohne Probleme bis man Bilder uploaden möchte.Das erste und 2. ging dann hatte ich den Effekt keines der Bilder wurde hochgespielt mehr.Da ich alle mit Handy gemacht habe und sie gleich groß sind bin ich nicht genau dahinter gekommen,so das es mal jemand noch testen müsste.Upload Limit habe ich auch genug.Ich hatte Einstellung Größe optimal eingestellt.Das einzige ist was ich noch nicht getestet habe bzw. noch nicht angepasst habe sind die Themen Perfection,da ichmich mit Bootrap noch nicht so beschäftigt habe.Vorerst habe ich jetzt die Stable Xoops wieder drin da geht es problemlos,unabhängig der Größe.Es ist genau so eingestellt wie zuvor.



trucker2006

Dokuschreiber
Gepostet am:02.04.2021 10:27
trucker2006
trucker2006 Offline (Show more)
Dokuschreiber
Posts: 31
Since: 23.01.2010
#20

Aw: Erbitte 2 Sachen

Vielen lieben Dank



TopTop
« 1 (2) 3 4 5 ... 4706 »



Aktuell aus dem Forum

Forum Thema Antworten Views Letzter Beitrag
sonstige Module wgGallery und wgSitenotice 0 1045 29.12.2021 21:15
Goffy Gehe zum letzten Beitrag
sonstige Module wgTeams und wgTimelines 0 1039 29.12.2021 20:33
Goffy Gehe zum letzten Beitrag
OffOffTopic Frohe Weihnachten und Prosit 2022 0 1116 22.12.2021 11:11
Goffy Gehe zum letzten Beitrag
XOOPS-Themes u. Grafik für XOOPS 2.3 Publisher New Theme 1 1805 30.11.2021 17:27
Goffy Gehe zum letzten Beitrag