MyXoops Forum

Forum - All Posts - myXOOPS German Support

Forum Index


Board-Index » All Posts (migoe)

BottomBottom



migoe

"myXOOPs"-Könner
Gepostet am:30.05.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#11

Aw:: CBB 4.02 ab XOOPS 2.4.3

Hallo Alfred,

ich hoffe, Du findest dafür eine Lösung. Momentan sind es ja "nur" 6 Beiträge, die ich manuell aus der Datenbank löschen müßte, aber das könnte ja schnell richtig in Arbeit ausarten

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:30.05.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#12

Aw:: CBB 4.02 ab XOOPS 2.4.3

Hallo Alfred,

ich bin gerade über einen weiteren Fehler gestolpert. Wenn Beiträge gelöscht wurden und wiederhergestellt werden sollen, gibt es bei einigen Beiträgen folgende Fehlermeldung über den Debug-Modus:

Fatal errorCall to a member function getVar() on a non-object in /is/htdocs/wp1145690_XUKMFY923A/www/modules/newbb/class/post.php on line 571


Wie gesagt, bei den meisten Beiträgen, die ich wiederhergestellt habe, war das kein Problem, aber 6 Beiträge kann ich einfach nicht wiederherstellen, weil ich eine weiße Seite mit dieser Meldung erhalte.

Xoops 2.3.3
CBB 4.02 Rev40 von heute (Fehler war in der alten Rev35 auch drin)
Die User, von denen die Beiträge sind, sind aktiv und können auch noch Beiträge schreiben.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:27.05.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#13

Aw:: E-Mail bei neuer PM! Geht das?

Hallo Alfred,

Zitat:

alfred schrieb:

mal nen Schnellcrashkurs dazu:

- öffne die pmlite.php ...

Das ganze kann man noch schön ausbauen



ich habe aus uralten Xoops 2.0 Zeiten eine Hack gefunden, der früher mal gepasst hat, nun aber leider nicht mehr funktioniert. Wie müßte ich den anpassen, damit er auch mit Version 2.3.3 und eProfile 1.68 funktioniert?

// Hack by marcan to receive Private Message email notification
       
$userHandler =& xoops_gethandler('user');
       
$toUser =& $userHandler->get($HTTP_POST_VARS['to_userid']);
       
// Only send email notif if notification method is mail
       
if ($toUser->notify_method() == 2) {
          
$xoopsMailer =& getMailer();
          
$xoopsMailer->useMail();
          
$xoopsMailer->setToEmails($toUser->email());
          
$xoopsMailer->setFromEmail($xoopsConfig['adminmail']);
          
$xoopsMailer->setTemplate('new_pm.tpl');
          
$xoopsMailer->assign('X_SITENAME'$xoopsConfig['sitename']);
         
$xoopsMailer->assign('X_SITEURL'XOOPS_URL."/");
         
$xoopsMailer->assign('X_ADMINMAIL'$xoopsConfig['adminmail']);
         
$xoopsMailer->assign('X_UNAME'$toUser->uname());
          
$xoopsMailer->assign('X_FROMUNAME'$xoopsUser->uname());
         
$xoopsMailer->assign('X_SUBJECT'$myts->stripSlashesGPC($HTTP_POST_VARS['subject']));
          
$xoopsMailer->assign('X_MESSAGE'$myts->stripSlashesGPC($HTTP_POST_VARS['message']));  
          
$xoopsMailer->assign('X_ITEM_URL'XOOPS_URL "/readpmsg.php?start=" $pm->getVar('msg_id') . "&total_messages=1"); 
          
$xoopsMailer->setFromName($xoopsConfig['sitename']);
          
$xoopsMailer->setSubject(sprintf(_PM_MESSAGEPOSTED_EMAILSUBJ$xoopsConfig['sitename']));
         
$xoopsMailer->setBody($HTTP_POST_VARS['message']);
          
$xoopsMailer->send();
       }


Der Vorteil an dieser Lösung ist das Template, welches mitgeliefert wurde und das individuell gestaltet werden kann. Das Template liegt im Verzeichnis ROOT/language/german/mail_templates/

Gut an diesem Hack ist auch, dass nur die User eine Mailbenachrichtigung erhalten, die das in den persönlichen Einstellungen des Kontos ausgewählt haben. Der Hack, den Du hier auf die schnelle gepostet hast, verschickt immer eine Mail, auch wenn der User das nicht möchte.

Der Hack von marcan kann doch sicher relativ einfach angepasst werden, oder? Über einen Hinweis würde ich mich sehr freuen - vielleicht gibt es ja eine noch bessere Lösung?

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:27.05.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#14

Aw:: CBB 4.02 ab XOOPS 2.4.3 - Fehlerhafte Datumsanzeige

Hallo Lord,

tatsächlich lag hier das Problem und ich hatte das schon mal, wußte aber die Lösung nicht mehr. Nach dem Update auf 4.02 gab es diese seltsame Anzeige plötzlich wieder, obwohl ich nichts geändert hatte. In der global.php waren diese beiden Zeilen aber nicht mehr Vorhanden - komisch...wo sind die nur hin...?

Jetzt geht es auf alle Fälle und alle, die das Problem auch haben sollten, wissen jetzt Bescheid!

Vielen Dank

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:25.05.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#15

Aw:: CBB 4.02 ab XOOPS 2.4.3 - Fehlerhafte Datumsanzeige

Einen Bug habe ich noch gefunden. Im Block "Aktuelle Beiträge" (Recent Posts) wird das Datum nicht korrekt angezeigt, wenn der User nicht eingeloggt ist. Im Anhang habe ich einen Screenshot beigefügt. Es geht mir um die komische Anzeige beim Datumsfeld ganz rechts -> Europe/Berlin00000031Europe/Berlin. Mir ist schon klar, dass das was mit den Formateinstellungen für das Datum zu tun hat, weil die Anzeige nur erscheint bei Beiträgen von heute und gestern. Vielleicht liegt es ja auch an was anderem?

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:19.05.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#16

Aw:: Social Profile im Test - Signatur ändern nicht möglich

Hallo Alfred,

Mitglieder, deren Username kürzer als 5 Buchstaben ist, können ihre Signatur nicht ändern. Es wird eine Fehlermeldung angezeit, dass der Username zu kurz wäre.

Das ist doch sicher ein Fehler.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:13.05.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#17

Aw:: Social Profile im Test

Ich habe das Profile Modul jetzt auch eine Zeit getestet und finde es tatsächlich wesentlich gelungener wie alle anderen Lösungen. Leider gibt es noch keine Möglichkeit für einen "Geburtstagskind Block", wo z.B. angezeigt werden könnte, welche Mitglieder heute Geburtstag haben, mit Möglichkeit, dem User eine PM oder einen Eintrag ins Gästebuch zu schreiben. Ist sicher für viele andere auch eine interessante Sache.

Ich weiß, ich bin schon länger nicht mehr aktiv hier auf der Seite gewesen und habe erst vor 10 Tagen wieder begonnen, mich mit Xoops zu beschäftigen, aber es ist erstaunlich, was Ihr in der Zwischenzeit hier alles bewegt habt. Meinen Respekt dafür und auch Dank für die Zeit und Arbeit, die Ihr alle, vor allem aber alfred hier in die Seite und die Software stecken.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:23.10.2009
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#18

Aw:: Liaise 1.26 + XOOPs 2.3.1

Hallo Alfred,

so hab ich mir das auch gedacht, habe aber keine Erklärung, warum das so ist. Das Modul selber hat vor dem Umstieg auf X 2.3.3 funktioniert. Bis März diesen Jahres war es im täglichen Einsatz, danach habe ich es ein paar Monate lang nicht gebraucht. Zwischenzeitlich habe ich die Xoops-Version aktualisiert und bei einem kurzen Check keinen Fehler festgestellt. Nunja, bis ich halt gestern abend das Modul wieder in produkiven Einsatz bringen wollte und beim Aufruf der index.php diesen Fehler bekommen habe.

Wie gesagt, am Modul wurde nichts geändert, aber das Xoops ist neu - allerdings wurde auf xoops.org über diesen Fehler nicht berichtet und es gibt einige User, die davon berichten, das Modul würde in der vorliegenden Version 1.26 problemlos laufen. Jetzt hoffe ich, es ist nur ein kleiner Hack nötig, um das Modul zum Laufen zu bekommen.

Hier der komplette Block aus der Datei:

$c 0;
$eles = array();
foreach( 
$form_output->getElements() as $e ){
 
$id $req $name $ele_type false;
 
$name $e->getName();
  
$caption $e->getCaption();
  if( !empty(
$name) ){
    
$id str_replace('ele_'''$e->getName());
 }elseif( 
method_exists($e'getElements') ){
    
$obj =& $e->getElements();
    
$id str_replace('ele_'''$obj[0]->getName());
    
$id str_replace('[]'''$id);
 }
 if( isset(
$elements[$id]) ){
    
$req $elements[$id]->getVar('ele_req') ? true false;
    
$ele_type $elements[$id]->getVar('ele_type');
 }else{
    
$req false;
 }
 
$eles[$c]['caption']  = $caption;
 
$eles[$c]['name']   = $name;
  
$eles[$c]['body']   = $e->render();
 
$eles[$c]['hidden']   = $e->isHidden();
 
$eles[$c]['required'] = $req;
 
$eles[$c]['ele_type'] = $ele_type;
  
$c++;
}


In der Admin klappt alles wunderbar...

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:23.10.2009
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#19

Aw:: Liaise 1.5 + Xoops 2.3.3 Captcha

Hallo Zusammen,

ich hatte lange nicht mehr mit Liaise zu tun und heute erst bemerkt, dass es mit der Version 1.26 und X 2.3.3 Probleme gibt, die ich aber leider nicht lösen kann.

Die Admin funktioniert soweit wie gehabt, leider erscheint aber nur eine leere Seite, wenn ich ein Formular aufrufe und folgende Meldung bringt der Debug-Modus:

Fatal errorCall to a member function getName() on a non-object in /is/htdocs/wp1145690_XUKMFY923A/www/modules/liaise/include/form_render.php on line 73


An der besagten Stelle der genannten Datei sieht es so aus:

$id str_replace('ele_'''$obj[0]->getName());


Leider habe ich auch auf xoops.org keine Lösung dafür gefunden. Ab und zu wird eine Version 1.27 erwähnt, die ich aber nirgends finden kann, bzw. der einzige Link den ich gefunden habe ist tot.

Ich würde mich über Tipps und Ratschläge - oder Lösungen freuen...

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:12.05.2009
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#20

Aw:: Wie kann das Captcha aus dem Frameworks von Xoops 2.3 in alte Module eingebaut werden?

Lieber Alfred,

jetzt klappt das wunderbar. Vielen Dank für die Hilfe, ich bin mir sicher, auch andere werden davon profitieren und ich werde auch andere Bereiche meiner Seite auf diese Art und weise schützen können.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...



TopTop
« 1 (2) 3 4 5 ... 31 »