MyXoops Forum

Forum - All Posts - myXOOPS German Support

Forum Index


Board-Index » All Posts (tohm)

BottomBottom



tohm

"myXOOPs"-Neuling
Gepostet am:20.06.2015
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#1

Aw: News 1.67 und Tag 2.31 mit xoops 2.5

hatte vergessen den Status von "offen" auf "erledigt" zu stellen. Funktioniert jetzt ja wie bereits geschrieben...

Danke
Thomas


tohm

"myXOOPs"-Neuling
Gepostet am:19.06.2015
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#2

mainfile.php

Saublöde Frage ich weiß aber irgendwie stehe ich gerade auf dem Schlauch...

Unter xoops 2.0.16 hatte ich in der mainfile.php folgende Section:

// Database
// Choose the database to be used
define('XOOPS_DB_TYPE', 'mysql');

// Table Prefix
// This prefix will be added to all new tables created to avoid name conflict in the database. If you are unsure, just use the default 'xoops'.
define('XOOPS_DB_PREFIX', 'xoops');

// Database Hostname
// Hostname of the database server. If you are unsure, 'localhost' works in most cases.
define('XOOPS_DB_HOST', 'localhost');

// Database Username
// Your database user account on the host
define('XOOPS_DB_USER', 'xxx');

// Database Password
// Password for your database user account
define('XOOPS_DB_PASS', 'xxx');

// Database Name
// The name of database on the host. The installer will attempt to create the database if not exist
define('XOOPS_DB_NAME', 'xxx');

// Use persistent connection? (Yes=1 No=0)
// Default is 'Yes'. Choose 'Yes' if you are unsure.
define('XOOPS_DB_PCONNECT', 0);

Unter xoops 2.5.7 fehlt das aktuell komplett in der mainfile.php... Kann ich das einfach ergänzen oder steht diese Info jetzt woanders??


Danke
Thomas


tohm

"myXOOPs"-Neuling
Gepostet am:19.06.2015
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#3

Aw: News 1.67 und Tag 2.31 mit xoops 2.5

Hi,

ich habe News und Tag nochmals deinstalliert und neu installiert und jetzt funktioniert es so wie von Dir beschrieben...

Komisch. Ich hatte diese und andere Tag und News Versionen ausprobiert. Immer ohne Erfolgt...

Manchmal ist es doch besser das Modul nochmals zu deinstallieren...


Vielen Dank
Thomas


tohm

"myXOOPs"-Neuling
Gepostet am:13.06.2015
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#4

Aw: News 1.67 und Tag 2.31 mit xoops 2.5

News ist 1.67 und Tag die Version 2.31 aus folgendem Paket:

XOOPS25_BasicModulePack_1.0-beta1_Mamba

Heruntergeladen auf Sourceforge - xoops2.5 - Modul Packages...


Danke
Thomas


tohm

"myXOOPs"-Neuling
Gepostet am:12.06.2015
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#5

News 1.67 und Tag 2.31 mit xoops 2.5

Hallo,
bin gerade dabei eine Seite mit Xoops 2.0.16 auf 2.5 zu aktualisieren. Sprich komplett neu aufzusetzen.

Die Kombination News und Tag hat in 2.0.16 super funktioniert. Hat man im Artikel ein Tag eingetragen so wurde dieser erkannt. In der Wortwolke ein Klick auf einen Tag und man war in dem Artikel...

Bei 2.5 funktioniert das irgendwie nicht mehr. Ich kann Tags bei News ergänzen. Diese werden automatisch erkannt und in der Wortwolke dargestellt ABER ein Klick auf den Tag ist ohne Wirkung. Ich bekomme den Artikel NICHT angezeigt..

Habe schon gegooglet und bei xoops.org geschaut aber noch nicht den entscheidenenden Hinweis gefunden...

Ein Tipp wäre super.

Danke

Thomas

(der Link sieht so aus:
modules/tag/view.tag.php/tagname

und früher war das so:
modules/tag/view.tag.php?62
(sprich die ID des News Artikels))


tohm

"myXOOPs"-Neuling
Gepostet am:10.11.2014
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#6

Aw: Error Reporting ausschalten

Hallo,

der Debug Modus ist ausgeschaltet...

Sonstige Idee?!


Danke
Thomas


tohm

"myXOOPs"-Neuling
Gepostet am:09.11.2014
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#7

Error Reporting ausschalten

Hallo,

ich habe noch eine ältere Version von Xoops laufen. Bekomme jetzt folgende Fehlermeldungen (wahrscheinlich wegen PHP 5.4):

Strict Standards: Non-static method Protector::getInstance() should not be called statically in /web/1/000/031/194/92250/egoprtetr/modules/protector/include/precheck_functions.php on line 12

Strict Standards: Non-static method XoopsLogger::instance() should not be called statically in /web/1/000/031/194/92250/htdocs/include/common.php on line 116

Strict Standards: Non-static method XoopsLogger::instance() should not be called statically in /web/1/000/031/194/92250/htdocs/class/logger.php on line 228

Jetzt wollte ich das Error reporting "ausschalten". Habe dazu in der php.ini folgende Zeile aktiviert:

error_reporting = E_COMPILE_ERROR|E_ERROR|E_CORE_ERROR

Die Fehlermeldungen kommen aber immer noch. Cache am Browser habe ich gelöscht. Template_C files auch.

Wie verschwinden die Fehlermeldungen?

Danke. Thomas


tohm

"myXOOPs"-Neuling
Gepostet am:07.07.2012
tohm
tohm Offline (Show more)
"myXOOPs"-Neuling
Posts: 8
Since: 06.09.2007
#8

Aw: pical fehler

Hallo,
bin/war auch betroffen:

So funktioniert es bei mir:
-> patTemplate.php
Zeile ca. 466 wie folgt ändern:
neu:
if ( preg_match( "//i", $line, $regs ))
alt:
//if ( eregi( "", $line, $regs ) )

Zeile ca. 510 wie folgt ändern:
neu:
elseif ( preg_match( "/<\/patTemplate:([[:alnum:]]+)>/i", $line, $regs ) )
alt:
//elseif ( eregi( "", $line, $regs ) )

-> class/piCal.php
Zeile ca. 194 wie folgt ändern:
neu:
if( ! ( preg_match( "<^([0-9][0-9]+)[-./]?([0-1]?[0-9])[-./]?([0-3]?[0-9])$>" , $setdate , $regs ) && checkdate( $regs[2] , $regs[3] , $regs[1] ) ) ) {
preg_match( "<^([0-9]{4})-([0-9]{2})-([0-9]{2})$>" , date( 'Y-m-d' ) , $regs ) ;
$this->use_server_TZ = true ;
alt:
//if( ! ( ereg( "^([0-9][0-9]+)[-./]?([0-1]?[0-9])[-./]?([0-3]?[0-9])$" , $setdate , $regs ) && checkdate( $regs[2] , $regs[3] , $regs[1] ) ) ) {
// ereg( "^([0-9]{4})-([0-9]{2})-([0-9]{2})$" , date( 'Y-m-d' ) , $regs ) ;
// $this->use_server_TZ = true ;


Ich hoffe das hilft Dir weiter.

Grüße
Thomas



TopTop