MyXoops Forum

Forum - All Posts - myXOOPS German Support

Forum Index


Board-Index » All Posts (migoe)

BottomBottom



migoe

"myXOOPs"-Könner
Gepostet am:24.06.2015
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#1

Aw: Nach Bearbeiten der Templates werden Änderungen nicht übernommen

Hallo Goffy,

Zitat:
Goffy schrieb am 22.06.15 07:05 Uhr

Ich denke, dass Problem sind nicht die Templatedateien selbst, zumal es anscheinend bei allen Themes so zu sein scheint.


danke für Deine Hilfe. Ich denke auch nicht, dass es an den Templates liegt, sondern eher an einer Funktion von Xoops, die irgendwo hängt.

Ich werde Deinen Rat, ein neues Xoops aufzusetzen und dort mein Theme zu probieren, beherzigen. Bisher habe ich meine Seite auf dem eigenen Rechner quasi gespiegelt in einer Test-Installiation laufen und da klappt das mit der Übernahme der Templates auch nicht, deshalb bin ich davon ausgegangen, es liegt an Xoops selber. Aber es könnte ja auch an irgendeinem Hack liegen, den ich seit 2003 eingebaut habe und der jetzt eine Funktion blockiert.

Ich werde hier berichten...Danke schon mal für die Hilfe und Zeit.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:21.06.2015
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#2

Aw: Nach Bearbeiten der Templates werden Änderungen nicht übernommen

Hallo Goffy,

Zitat:
Goffy schrieb am 21.06.2015 10:47 Uhr

also, ich arbeite nur mit dem Themes-Verzeichnis, alles andere greif ich gar nicht an.


ich arbeite auch nur mit den Dateien im Themes-Verzeichnis. Die Templates musste ich bisher auch nicht anfassen und habe mich deshalb auch nicht mit den speziellen Änderungen befasst. Als ich 2003 meine Seite erstellt habe, wurden alle Templates noch direkt in den Modules/Templates-Verzeichnissen geändert/angepasst. Das hat sich zwischenzeitlich wohl geändert und ich möchte jetzt einige Dinge anpassen oder hardgecodete Angaben in den Templates ändern. Die Änderungen an der style.css und anderen Dateien im Verzeichnis /themes/meinTheme werden auch problemlos sofort übernommen und angezeigt, aber halt leider nicht die Änderungen an den .html-Dateien im Verzeichnis /themes/meinTheme/modules/...

Das verwendete Theme spielt dabei absolut keine Rolle, denn egal, welches Theme ich einstelle, es werden keine Änderungen übernommen, die ich in den Template-Dateien eingebe. Das ist schon ziemlich doof!

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:20.06.2015
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#3

Aw: Nach Bearbeiten der Templates werden Änderungen nicht übernommen

Zitat:
Goffy schrieb am 20.06.15:

2) xoops prüft zuerst, ob es im Theme einen Template-Ordner zu den einzelnen Modulen gibt
Beispiel Modul newbb bei Template xbootstap: wenn unter themes/xbootstrap/modules/ ein Ordner newbb aufscheint, dann werden diese Templatedateien herangezogen. Du must daher auch diese Dateien bearbeiten.
Durch diese (auf den ersten Blick vielleicht verwirrende) Vorgangsweise wird sichergestellt, dass
a) die Originaldateien unter modules/newbb/templates nicht verändert werden müssen
b) die templates für jedes theme seperat angepasst werden können


Hallo und danke für die Meldung. Das ist mir bekannt und ich habe alle Kombinationen ausprobiert:

-> Änderung der Templates über den Manager - KEINE WIRKUNG
-> Änderung im Themes-Verzeichnis - KEINE WIRKUNG
-> Änderung im Modules-Verzeichnis - KEINE WIRKUNG
-> Änderung in der Datenbank direkt - KEINE WIRKUNG

Ich habe also bei keinem Modul die Möglichkeit, die Templates zu ändern, egal auf welchem Weg und das ist ein Problem, weil ich nicht alles über das Theme und CSS lösen kann.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:20.06.2015
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#4

Nach Bearbeiten der Templates werden Änderungen nicht übernommen

Grüß Gott zusammen,

ich bin zwar schon seit 2003 mit Xoops unterwegs, habe aber heute ein Problem, mit dem ich selber nicht mehr klar komme und hoffe, hier findet sich jemand, der eine Lösung weiß:

Ich überarbeite gerade die Templates von einige Modulen und habe das Problem, dass ich zwar verschiedene Möglichkeiten und Stellen habe, um Templates zu ändern, aber die Änderungen werden nicht angenommen/angezeigt.

Ein Beispiel:

Das Template des Forenmoduls newbb (Version 4.3) für die index.html habe ich zuerst im Template-Manager des Adminbereichs bearbeitet und das Diskettensymbol angeklickt. Danach kam die Meldung "Speichern" sonst nichts. Bei der Aktualisierung der Seite wurden die Änderungen nicht angezeigt.

Ich hab es dann über die Datein auf dem Server versucht

-> zuerst die index.html im Verzeichnis /themes/-meinTheme-/modules/newbb/
-> Die Datei ließ sich nicht zurück auf den Server übertragen, wegen Schreibrechten
-> Ich habe sie dann auf dem Server entfernt und vom Rechner übertragen. Resultat war...
-> KEINE WIRKUNG

-> danach die index.html im Verzeichnis /modules/newbb/templates/
-> KEINE WIRKUNG

So geht es mir auch mit den Templates von /modules/AMS/ und modules/news/

Ich habe ja schon gelesen, dass es seit Xoops 2.5 eine andere Vorgehensweise bei den Templates gibt, aber leider habe ich keine Lösung für die Probleme, die andere scheinbar auch haben, finden können.

Gibt es einen Trick, der noch nicht verraten wurde?

Mit "alten" Modulen bei denen direkt in den php-Dateien Änderungen vorgenommen werden müssen, klappt die Übernahme sofort, was auch nachvollziehbar ist. Leider nicht bei den Templates.

Leider kann ich nicht sagen, ob ich vor dem Update auf die Version 2.5.6 (die läuft nämlich bei mir) im Template-Manager das Templateset auf "default" geändert habe und es deshalb nicht klappt. Sicher ist, dass ich in den Einstellungen die Option "Templates auf Änderungen prüfen?" auf "JA" steht.

migoe

P.S. Direkt in der Datenbank habe ich die Templates auch gefunden und die Änderungen eingetragen und gespeichert - trotzdem KEINE WIRKUNG!
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:06.11.2013
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#5

Aw: Internal Sever Error 500 bzw. weiße Seite nach Speichern von Änderungen (DH-Info - Adminbereich)

Hallo Marcus,

die Art des Fehlers lässt darauf schließen, dass eine Einstellung am Server geändert wurde oder der Server einfach überlastet ist. Könnte an Deiner Seite liegen, oder Deine Seite liegt auf einem Server, der einfach mittlerweile überlastet ist. Am Besten ist, Du versuchst erstmal, mit dem Provider in Kontakt zu treten - der soll mal nach dem Server sehen.

Wenn es Dein eigener Server ist, dann solltest Du selber mal schauen

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:06.09.2013
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#6

Aw: Direct access not allowed - Meldung seit Update auf 2.5.6

Lieber Mambax7,

vielen Dank, das war der richtige Tipp - vielen Dank für die schnelle und vor allem sehr effektive Hilfe.

Bin mir sicher, jetzt werden auch andere Xoops-User davon profitieren können.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:05.09.2013
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#7

Direct access not allowed - Meldung seit Update auf 2.5.6

Ich bin ein Xoops-User seit Version 1 und habe bisher noch jedes Problem irgendwie gelöst bekommen - vor allem natürlich durch diese tolle Plattform hier und xoops.org.

Heute habe ich mal wieder ein Anliegen, bei dem ich selber nicht weiter komme:

Vor 2 Tagen habe ich ein mustergültiges Upgrade der Seite von 2.5.0 auf 2.5.6 vorgenommen und zunächst noch keine Probleme feststellen können. Nun habe ich aber von einigen Usern die Meldung bekommen, sie könnten keine PNs mehr schreiben, weil nach dem Absenden eine weiße Seite erscheint. Die PN wird teilweise aber versendet, ohne dass der User das aber irgendwie merken kann, bzw. fehlt der normalerweise folgende Hinweis. Ich habe den Protektor in Verdacht, finde aber die Ursache nicht.

Ein weiteres Problem, dass für die User auch sehr nervig ist: wenn man die Vorschau betrachten möchte, von dem was man geschrieben hat, erscheint nicht die selbe, sondern ein Hinweis darauf, dass der direkte Zugang nicht erlaubt ist. Ich habe da einen Screenshot beigefügt. Das Problem ist auf der gesamten Seite durchgehend so zu finden - also führe ich es auf das Upgrade zurück.

Wie krieg ich das wieder so, wie es war und sein sollte?

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:20.11.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#8

Aw:: PiCal mit Google-Maps-Karte

Hallo Goffy,

stimmt, ich habe Deinen Hack eingebunden und finde es toll, wie Du das für PiCal gelöst hast. Danke für die Bereitstellung. Tolle Seite übrigens!

Zitat:
Woher Du die entsprechenden Orstinfos bekommt, musst du Dir noch überlegen. Anbieten würde sich die Spalte 'location' in pical_event (= Ort in den Termindetails), dann muss dieser aber auch dementsprechend für Google-Maps verarbeitbar eingegeben sein


Am besten wäre es für die Besucher natürlich, wenn Sie direkt beim Eintragen eines neuen Termins in einer Karte den Veranstaltungsort "pinnen" könnten und die Koordinaten in die Datenbank eingetragen werden. Wenn der Termin dann aufgerufen wird, oder die Monats-, Wochen-, Tages- oder Listenansicht angezeigt wird, sollten die Termine als Pin in der Karte angezeigt werden. Dafür fehlt mir aber das Wissen. So wie es jetzt ist, kann ich gut mit leben und ich hoffe, ich konnte durch diesen Beitrag anderen helfen.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:16.11.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#9

PiCal mit Google-Maps-Karte

Vielleicht kann jemand damit etwas anfangen:

In der Datei XOOPS-ROOT/modules/piCal/class/piCal.php die Zeile 2167 (eventuell auch weiter oben bzw. unten, je nach Version und Hacks) ändern in

<td width='100%' align='center' colspan='2'
[!
IFRAME FILTERED! ] <br /><small>
<
a href='http://maps.google.de/maps?q=$location&um=1&ie=UTF-8&sa=N&hl=de&tab=wl' 
style='color:#0000FF;text-align:left'>Größere Kartenansicht</a></small></td>


und abspeichern. Ab sofort wird in der Detailansicht eines Termins unter den Detailangaben eine Google-Map eingebaut per IFrame, in der der Veranstaltungsort bereits gepinnt ist und man kann die Karte verwenden wie gewohnt bei Maps.

Eine Vorstellung, wie das aussieht erhält man auf meiner Webseite im Terminkalender...

Ich hatte ursprünglich vor, eine Kartenansicht für die Termine des Tages/der Woche/des Monats zu integrieren, dazu fehlen mir aber einfach die "geistigen" Fähigkeiten bzw. das PHP-Wissen.

Wenn sich jemand dazu berufen fühlt und solch einen Hack produziert, wäre das natürlich schön, ansonsten ist das vielleicht für den einen oder anderen eine praktikable Lösung.

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...


migoe

"myXOOPs"-Könner
Gepostet am:03.06.2010
migoe
migoe Offline (Show more)
"myXOOPs"-Könner
Posts: 527
Since: 02.11.2002
#10

Aw:: CBB 4.02 ab XOOPS 2.4.3

Hallo Alfred,

reproduzieren is leider nicht, weil es seither dieses Problem gar nicht mehr gab und ich auch nur durch Zufall darüber gestolpert bin. Komisch ist aber etwas anderes:

Seit ein paar Tagen melden User, dass Beiträge, die sie geschrieben haben auf einmal nicht mehr sichtbar waren, nachdem sie den Beitrag noch einmal bearbeitet haben. Vom Ablauf her war das so:

- User schreibt einen Beitrag und senden diesen ab
- User liest den Beitrag und stellt einen Rechtschreibfehler fest
- User klickt auf den Button "ändern" und verbessert den Fehler
- User gibt Grund für Bearbeiten an und klickt auf Absenden
- Beitrag wird im Block "Neue Beiträge" angezeigt, aber nicht, wenn der Thread direkt aufgerufen wird
- Admin kann den Beitrag auch nicht "finden", in der Datenbank ist der Beitrag noch, jedoch bei "Approved" mit Kennzeichen 2 hinterlegt

Warum das so ist, weiß ich leider auch nicht, wenn ich direkt in der Datenbank bei "Approved" von "2" auf "1" ändere, ist der Beitrag wieder da.

Das passiert aber nur bei ein paar Usern. Ich denke, es hat was mit den Berechtigungen für die Gruppe zu tun, in der diese User sind. Wenn ich aber in der Admin die Berechtigung "Kann Beiträge ohne Freigabe schreiben" und "Kann Beiträge bearbeiten" setzen möchte erhalte ich die Meldung, dass ich keine Berechtigung habe, diese Einstellung zu ändern und ich mich an den Admin wenden soll

Hier ist wohl noch ein Fehler im Gebälk...

migoe
Wenn Du denkst Du denkst, dann denkst Du nur, Du denkst
--- www.liedermacher-forum.de ---...



TopTop
(1) 2 3 4 ... 31 »