MyXoops Forum

Re: Fehler bei erstellen eines Beitrages ... Array ( ) (Nachtrag 26.12.) [Module für Forenlösungen] - myXOOPS German Support

Ronte

"myXOOPs"-Fortgeschrittener
Gepostet am:25.12.2008 17:55
Ronte
Ronte Offline (Show more)
"myXOOPs"-Fortgeschrittener
Posts: 244
Since: 11.01.2005
#9

Re: Fehler bei erstellen eines Beitrages ... Array ( ) (Nachtrag 26.12.)

Nach Installation von aktueller Xoops-Version und CBB 3.08 -utf erscheint auch der Fehler

Could not insert forum post

Array
(
)

In der alten Version lief ebenfalls CBB 3.08, so das mir der Fehler momentan nicht logisch vorkommt

Nachtrag 26.12.2008

CBB deinstalliert, gelöscht und wieder neu aufgesetzt. Im bestehenden Erstforum konnte einwandfrei eine Nachricht abgespeichert werden.

MySQL-Tabellen aus der alten CBB 3.08 Version unter Vorgänger-Xoops-Version wieder eingespielt.... es kann kein Beitrag abgespeichert werden. Fehlermeldung wie oben.

Tabellen gesichtet
Folgende Unterschiede gibt es zur ehemaligen genutzten CBB-Version 3.08 und der jetzigen CBB-Version 3.08-UTF. Alle anderen nicht aufgeführten Tabellen von CBB sind identisch.

alte Version neue Version
xoops_bb_stats werden nicht erstellt
xoops_bb_type dito
xoops_bb-type_forum dito
xoops_bb_user_stats dito

Ronte

"myXOOPs"-Fortgeschrittener
Gepostet am:25.12.2008 14:40
Ronte
Ronte Offline (Show more)
"myXOOPs"-Fortgeschrittener
Posts: 244
Since: 11.01.2005
#8

Re: Fehler bei erstellen eines Beitrages

Hi Alfred,

nach dem deaktivieren des Debugs kam der Fehler in der Testversion nicht mehr vor. Mittlerweile haben wir nun auch unser Forum auf die neue Version aktualisiert.

Advertisement

Gepostet am:0
Advertisement (Show more)
Posts: 0
Since: 0


Hier könnten Sie Ihre Anzeige aufgeben!
Bitte kontaktieren Sie uns, um mehr darüber zu erfahren.

alfred

Administrator
Gepostet am:23.12.2008 11:30
alfred
alfred Offline (Show more)
Administrator
Posts: 7613
Since: 06.12.2004
#7

Re: Fehler bei erstellen eines Beitrages

Hast du in den Voreinstellungen des CBB den Debug aktiviert ?
Wenn ja bitte ausschalten.

Ronte

"myXOOPs"-Fortgeschrittener
Gepostet am:22.12.2008 18:45
Ronte
Ronte Offline (Show more)
"myXOOPs"-Fortgeschrittener
Posts: 244
Since: 11.01.2005
#6

Re: Fehler bei erstellen eines Beitrages

Hallo Alfred,

mysql-Debug zeigt nur ein leeres Feld!

Da wir auch auf die aktuelle Xoops-Version updaten wollen, habe ich eine Testinstallation vorgenommen und cbb 3.08-utf installiert und die entsprechenden Tabellen übernommen.

Hier zeigt CBB 3.08 jeweils nun am Ende einer Seite folgendes an:

can not update online info: INSERT INTO xoops_bb_online (online_uid, online_uname, online_updated, online_ip, online_forum, online_topic) VALUES (0, '', 1229967308, '85.180.42.215', 0, 0)

Beim absenden eines neuen Beitrags folgt der Fehler:
Array (Klammer auf Klammer zu)

aktuell:
XOOPS Version - XOOPS 2.3.2
PHP Version - 4.4.0
MySQL Version - 4.1.13

Muki

Co-Administrator
Gepostet am:20.12.2008 23:28
Muki
Muki Offline (Show more)
Co-Administrator
Posts: 1903
Since: 18.04.2006
#5

Re: Fehler bei erstellen eines Beitrages

Zitat:

alfred schrieb:
was steht steht denn beim mysql-Debug für eine Fehlernummer dabei ?
Ich tippe auf ein leeres Feld was nicht sein darf

Bingo, poster_name ist leer, auch scheint das Feld IP den falschen Inhalt zu haben.
Zitat:
topic_id = 2819
forum_id = 276
post_time = 1229782252
poster_ip = 1437865465
poster_name =''
subject = 'test'
pid = 0
dohtml= 0
dosmiley = 1
doxcode = 1
dobr = 1
uid = 4
icon = ''
attachsig = 0
approved = 1
post_karma = 0
require_reply = 0


Muki
Es gibt keine dummen Fragen, nur dumme Antworten (Ausnahmen bestätigen die Regel).

alfred

Administrator
Gepostet am:20.12.2008 20:01
alfred
alfred Offline (Show more)
Administrator
Posts: 7613
Since: 06.12.2004
#4

Re: Fehler bei erstellen eines Beitrages

was steht steht denn beim mysql-Debug für eine Fehlernummer dabei ?
Ich tippe auf ein leeres Feld was nicht sein darf

Ronte

"myXOOPs"-Fortgeschrittener
Gepostet am:20.12.2008 17:21
Ronte
Ronte Offline (Show more)
"myXOOPs"-Fortgeschrittener
Posts: 244
Since: 11.01.2005
#3

Re: Fehler bei erstellen eines Beitrages

Hi!

Mysql-Version 4.1.13

Bis jetzt ist diese oder ähnliche Fehlermeldung anderweitig nicht aufgetaucht

mcleines

"myXOOPs"-Master
Gepostet am:20.12.2008 16:32
mcleines
mcleines Offline (Show more)
"myXOOPs"-Master
Posts: 1627
Since: 05.10.2004
#2

Re: Fehler bei erstellen eines Beitrages

Welche Mysql-Version verwendest du?

Bekommst du sonst auch noch irgendwo eine ähnliche Fehlermeldung?

Ronte

"myXOOPs"-Fortgeschrittener
Gepostet am:20.12.2008 15:18
Ronte
Ronte Offline (Show more)
"myXOOPs"-Fortgeschrittener
Posts: 244
Since: 11.01.2005
#1

Fehler bei erstellen eines Beitrages

Im Forum läuft CBB 3.08. Bei erstellen eines Beitrags wird folgende Fehlermeldung ausgegeben. Ist dieser bekannt und wie kann dieser behoben werden?

Danke für die Hilfe!

Could not insert forum post
Insert object error 
(queryF):INSERT INTO xoops_bb_posts (topic_id,forum_id,post_time,poster_ip,poster_name,subject,pid,dohtml,dosmiley,doxcode,dobr,uid,icon,attachsig,approved,post_karma,require_replyVALUES (2819,276,1229782252,1437865465,'','test',0,0,1,1,1,4,'',0,1,0,0)
Diesen Thread durchsuchen:  1 Anonyme Benutzer