MyXoops Forum

Aw:: Fehler im Head-Menü bei Theme XT-Game [XOOPS-Themes u. Grafik für XOOPS 2.4.X] - myXOOPS German Support

blindfoxx

"myXOOPs"-Neuling
Gepostet am:30.03.2010
blindfoxx
blindfoxx Offline (Show more)
"myXOOPs"-Neuling
Posts: 7
Since: 08.03.2010
#4

Aw:: Fehler im Head-Menü bei Theme XT-Game

Du wirst lachen, aber das war die Lösung.

Ist mir garnicht aufgefallen das dieses Zeichen in beiden Links gefehlt hat. Kleine Ursache - große Wirkung!

Firefox ist da wohl etwas fehlertoteranter als die anderen Browser.


Danke Bleekk.

Bleekk

Co-Administrator
Gepostet am:30.03.2010
Bleekk
Bleekk Offline (Show more)
Co-Administrator
Posts: 1504
Since: 16.12.2002
#3

Aw:: Fehler im Head-Menü bei Theme XT-Game

hier noch das menü-bild ohne diesen fuss


Datei anhängen:



gif  (0.00 KB)

Advertisement

Gepostet am:0
Advertisement (Show more)
Posts: 0
Since: 0


Hier könnten Sie Ihre Anzeige aufgeben!
Bitte kontaktieren Sie uns, um mehr darüber zu erfahren.

Bleekk

Co-Administrator
Gepostet am:30.03.2010
Bleekk
Bleekk Offline (Show more)
Co-Administrator
Posts: 1504
Since: 16.12.2002
#2

Aw:: Fehler im Head-Menü bei Theme XT-Game

mir fällt nur auf dass dir im link "forum" ein ">" fehlt.

so wäre es richtig
<li class="<{if $xoops_dirname == "newbb"}>current<{/if}>"><a href="<{xoAppUrl modules/newbb/}>">Forum</a></li>

blindfoxx

"myXOOPs"-Neuling
Gepostet am:30.03.2010
blindfoxx
blindfoxx Offline (Show more)
"myXOOPs"-Neuling
Posts: 7
Since: 08.03.2010
#1

Fehler im Head-Menü bei Theme XT-Game

Hallo Community.
Eins vornweg: ich bin nicht so bewandert was den Umgang mit PHP, oder HTML angeht. Bin also mehr der Copy/Paste-Typ.

Trotzdem war ich mir eigentlich sicher das ich das Menü im Header des xt-game Themes richtig in der theme.html geändert habe.

Der ursrüngliche Code sah folgendermaßen aus:
<!-- Navigation Menu -->
 <
div id="menu">
   <
ul>
      <
li class="<{if $xoops_dirname == "system"}>current<{/if}>"><a href="<{xoAppUrl }>">Home</a></li>
     <
li class="<{if $xoops_dirname == "news"}>current<{/if}>"><a href="<{xoAppUrl modules/news/}>">Blog</a></li>
      <
li class="<{if $xoops_dirname == "extgallery"}>current<{/if}>"><a href="<{xoAppUrl modules/extgallery}>">Photos</a></li>
     <
li class="<{if $xoops_dirname == "newbb"}>current<{/if}>"><a href="<{xoAppUrl modules/newbb/}>">Forum</a></li>
     <
li><a href="#">Links</a></li>
      <
li class="<{if $xoops_dirname == "liaise"}>current<{/if}>"><a href="<{xoAppUrl modules/liaise/}>">Contact</a></li>
   </
ul>
 </
div
  <!-- 
End header -->

Ich habe diesen Code meinen installierten Modulen angepasst. Nun sieht es so aus:
<!-- Navigation Menu -->
  <
div id="menu">
   <
ul>
      <
li class="<{if $xoops_dirname == "system"}>current<{/if}>"><a href="<{xoAppUrl }>">Home</a></li>
     <
li class="<{if $xoops_dirname == "newbb"}>current<{/if}>"<a href="<{xoAppUrl modules/newbb/}>">Forum</a></li>
      <
li class="<{if $xoops_dirname == "news"}>current<{/if}>"><a href="<{xoAppUrl modules/news/}>">Artikel</a></li>
     <
li class="<{if $xoops_dirname == "casdedi"}>current<{/if}>"><a href="<{xoAppUrl modules/casdedi/}>">Gästebuch</a></li>
     <
li class="<{if $xoops_dirname == "PDdownloads"}>current<{/if}>"<a href="<{xoAppUrl modules/PDdownloads/}>">Downloads</a></li>
      <
li class="<{if $xoops_dirname == "extgallery"}>current<{/if}>"><a href="<{xoAppUrl modules/extgallery}>">Gallerie</a></li
      <
li class="<{if $xoops_dirname == "impressum"}>current<{/if}>"><a href="<{xoAppUrl modules/impressum}>">Impressum</a></li>    
    </
ul>
 </
div
  <!-- 
End header -->
Eigentlich funktioniert das auch recht gut - aber nur mit Firefox. Sobald die Seite mit dem IExplorer oder Opera aufgerufen wird sind die Buttons "Forum" und "Downloads" ohne Funktion und nicht als Button sondern als Text dargestellt.
Kann mir al jemand der mehr Ahnung vom Code hat einen Tip geben wo mein Fehler liegt?

Xoops Version: 2.4.3

URL: http://www.foxxforce.de/page

Hier mal noch zwei Screenshots. Der erste mit Firefox 3.6.2 und der zweite mit Opera 10.51:

Datei anhängen:



jpg  (0.00 KB)


jpg  (0.00 KB)

Diesen Thread durchsuchen:  1 Anonyme Benutzer