MyXoops Forum

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen" [Die Installation und Administration von XOOPS 2.5.X] - myXOOPS German Support

BigWombat

"myXOOPs"-Neuling
Gepostet am:09.05.2019 17:52
BigWombat
BigWombat Offline (Show more)
"myXOOPs"-Neuling
Posts: 24
Since: 15.12.2007
#27

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

Habe die von Dir angepasste Version auf die verwendeten Funktionalitäten getestet, dabei noch einen Anzeigefehler im Theme-css beseitigt.

Einziger Fehler war beim Ändern einer Seite per Seite bearbeiten/erstellen:
Fatal error: Class 'XoopsMySQLDatabaseProxy' not found in /homepages/33/d36471187/htdocs/bs/bs_cms_lib/modules/protector/class/ProtectorMysqlDatabase.class.php on line 14

Dies konnte man allerdings durch temporäres Deaktivieren des Protectors umgehen.

Um wieder auf eine Standardinstallation zu kommen führte ich ein ordnungsgemäßes XOOPS-Upgrade auf 2.5.9 durch, das selbst ohne Fehler durchlief. Allerdings besteht der o.g. Fehler bei der Seitenerstellung/-änderung weiterhin. Ansonsten ist alles bestens.

Bzgl. den Erweiterungen habe ich auch auf Unterschiede kontrolliert, die umfangreichen phpinfo()-Informationen aller 4 Installationen sind identisch, d.h. es kann bei dieser kaum etwas fehlen, das bei den anderen vorhanden ist.

Falls ich zu schnell mit meinem Vorgehen war kann ich selbstverständlich kurzfristig wieder den Stand von Deiner letzten Bearbeitung herstellen

BigWombat

"myXOOPs"-Neuling
Gepostet am:05.05.2019 22:35
BigWombat
BigWombat Offline (Show more)
"myXOOPs"-Neuling
Posts: 24
Since: 15.12.2007
#26

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

Ok, zunächst mal vielen Dank, ich werde den aktuellen Status auf jeden Fall sichern, falls ich irgendwelche falschen Dinge tun sollte.
Eine schöne Woche und viele Grüße,
Dieter

Advertisement

Gepostet am:0
Advertisement (Show more)
Posts: 0
Since: 0


Hier könnten Sie Ihre Anzeige aufgeben!
Bitte kontaktieren Sie uns, um mehr darüber zu erfahren.

alfred

Administrator
Gepostet am:05.05.2019 22:29
alfred
alfred Offline (Show more)
Administrator
Posts: 7610
Since: 06.12.2004
#25

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

Fertig, die Fehler erstmal ignorieren.
Ich werd mal schauen ob XOOPS 2.5.10 mit meiner Erweiterung läuft.
Dann bitte updaten, da sind dann auch die Fehler weg.

Bitte alle Fehler bezüglich der Datenbank hier melden, also wenn mysql-Errors kommen

BigWombat

"myXOOPs"-Neuling
Gepostet am:05.05.2019 21:12
BigWombat
BigWombat Offline (Show more)
"myXOOPs"-Neuling
Posts: 24
Since: 15.12.2007
#24

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

ok, Du kannst gerne noch was probieren, wenn es dann nicht geht spiele ich meine funktionierende Sicherung ein, stelle auf PHP5.6 zurück und nehme einen Monat den kostenpflichtigen Support, dann ist Zeit genug

alfred

Administrator
Gepostet am:05.05.2019 21:10
alfred
alfred Offline (Show more)
Administrator
Posts: 7610
Since: 06.12.2004
#23

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

nein, nicht die Datenbank das ist egal.
In dem PhP 7 fehlt die mysql-Erweiterung, es gibt nur mysqli und pdo.
Aber beides kann Xoops nicht.
Ich könnte jetzt deine Installation auf mysqli umstellen (ist nur 1 Datei)
aber ob alle Module dann fehlerfrei laufen ist nicht sicher, da manche eine eigene Verbindung zur DB aufbauen.
Hier liegt der Hase eben im Pfeffer.

Das ganze zu checken schaffen ich aber heute nicht mehr, könnte halt dann erst nächstes WE weitermachen.

Es ist mir immer noch ein Rätsel warum XOOPS die Entwicklung nicht auf pdo umstellt.

BigWombat

"myXOOPs"-Neuling
Gepostet am:05.05.2019 21:06
BigWombat
BigWombat Offline (Show more)
"myXOOPs"-Neuling
Posts: 24
Since: 15.12.2007
#22

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

einen eigenen Server habe ich nicht, aber wie kann ich erkennen, welche Installation wo liegt? Es sind alle Installationen eigene Verzeichnisse unter meiner einzigen Root, von daher kann ich mir nicht vorstellen, dass diese verteilt werden.

alfred

Administrator
Gepostet am:05.05.2019 20:58
alfred
alfred Offline (Show more)
Administrator
Posts: 7610
Since: 06.12.2004
#21

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

sind die auf dem gleichen Server?, denke mal nicht.
1und1 verteilt das sehr gerne.
Oder hast du einen eigenen Server?

BigWombat

"myXOOPs"-Neuling
Gepostet am:05.05.2019 20:57
BigWombat
BigWombat Offline (Show more)
"myXOOPs"-Neuling
Posts: 24
Since: 15.12.2007
#20

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

ok, werde ich tun, aber warum geht es dann bei den anderen drei Installationen problemlos?

alfred

Administrator
Gepostet am:05.05.2019 20:54
alfred
alfred Offline (Show more)
Administrator
Posts: 7610
Since: 06.12.2004
#19

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

dir fehlt die mysql-Extension (hat da 1und1 wieder mal zu schnell geschossen .-) )

API Extensions pdo_mysql,mysqli

Frag mal bitte beim Support nach.

BigWombat

"myXOOPs"-Neuling
Gepostet am:05.05.2019 19:39
BigWombat
BigWombat Offline (Show more)
"myXOOPs"-Neuling
Posts: 24
Since: 15.12.2007
#18

Aw: Weiße Seite bei "Einstellungen - System Voreinstellungen - Allgemeine Voreinstellungen"

Danke im Voraus, habe die Zugangsdaten per PN verschickt und mich hoffentlich beim Quick-and-dirty-EInrichten nicht vertan
Diesen Thread durchsuchen:  1 Anonyme Benutzer