MyXoops Forum

Forum - All Posts - myXOOPS German Support

Forum Index


Board-Index » Neue Beiträge

BottomBottom



WDC

"myXOOPs"-Könner
Gepostet am:Gestern 20:42
WDC
WDC Offline (Show more)
"myXOOPs"-Könner
Posts: 518
Since: 27.06.2004
#1

MyAlbum-P für Xoops 2.5.11

Hallo,

wie besprochen, poste ich mal meinen ersten Wunsch für ein Modul, was ich für Xoops 2.5.111 benötige.

Ich habe ein alte Version für Xoops 2.2.3, in wlechem ich sehr umfangreiche Änderungen vorgenommen hatte. Diese würde ich dann in die funktionierende Version einbauen. In einem anderen Galerie Modul wäre mir das leider nicht möglich.

https://www.myxoops.org/modules/tdmdow ... lefile.php?cid=60&lid=508

Ich hoffe dass das möglich ist.

Danke


Goffy

Co-Administrator
Gepostet am:09.08.2020 20:23
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 643
Since: 14.10.2004
#2

xNewsletter Tutorial auf Deutsch

Hallo zusammen

hab das deutsche xNewsletter-Benutzerhandbuch auf gibook hochgeladen.

https://xoops.gitbook.io/xnewsletter-tutorial/de

Ist zwar noch für die Version 1.2, aber die meisten Funktionen in der 1.3. sind gleich geblieben.
EDV = Epoche der Verzweiflung


WDC

"myXOOPs"-Könner
Gepostet am:09.08.2020 11:26
WDC
WDC Offline (Show more)
"myXOOPs"-Könner
Posts: 518
Since: 27.06.2004
#3

Aw: Module unter Xoops 2.5.10

Zitat:

Goffy schrieb:
Hi

Zitat:
Gegensatz zum localhost, direkt die 2.5.11 installiert, kein Update vom 2.5.10 gemacht. Kann es daran liegen?

nein, denke nicht dass es daran liegt.

Michael ist eh schon dran, weil es gibt einfach noch ein paar Probleme bei der Kombi newbb und xoopspoll

lass bitte die xoopspoll momentan noch inaktiv, und wir schauen derweil, dass wir den Rest fehlerfrei hingekommen ;)


Ja, dann machen wir das so. Dann wäre mir tatsächlich nur das Newsletter Modul erstmal wirklich noch wichtig.

Der Rest kann später kommen


Goffy

Co-Administrator
Gepostet am:09.08.2020 10:36
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 643
Since: 14.10.2004
#4

Aw: Module unter Xoops 2.5.10

Hi

Zitat:
Gegensatz zum localhost, direkt die 2.5.11 installiert, kein Update vom 2.5.10 gemacht. Kann es daran liegen?

nein, denke nicht dass es daran liegt.

Michael ist eh schon dran, weil es gibt einfach noch ein paar Probleme bei der Kombi newbb und xoopspoll

lass bitte die xoopspoll momentan noch inaktiv, und wir schauen derweil, dass wir den Rest fehlerfrei hingekommen ;)
EDV = Epoche der Verzweiflung


WDC

"myXOOPs"-Könner
Gepostet am:09.08.2020 10:05
WDC
WDC Offline (Show more)
"myXOOPs"-Könner
Posts: 518
Since: 27.06.2004
#5

Aw: Module unter Xoops 2.5.10

Zitat:

Goffy schrieb:
du kannst vorübergehend mal versuchen, die Konstante durch die entsprechende Zahl zu ersetzen
$criteria->add(new Criteria('mail_status'0'=')); // email not previously sent


laufen die übrigen Module jetzt?


habe ich gemacht. Dieser Fehler ist jetzt weg, nun kommen am laufenden Band andere. wflinks läuft, ich habe aus der xoopsversion händisch das Beta gelöscht, danke für den Tipp.

Zitat:

Goffy schrieb:
wann genau kommt eigentlich der Fehler?

Was führst du auf welcher Seite aus?


Der "behobene Fehler" kam direkt auf der Startseite, die komplette Seite wurde lahmgelegt. Ausgeführt auf dem Server wo die Seite live gehen wird.

Wenn ich wie oben beschrieben den Teil des Codes ändere kommt folgender Fehler

FehlerError: Class 'XoopsModules/Xoopspoll/Constants' not found in Datei /modules/xoopspoll/index.php Zeile 88

$limit    Request::getInt('limit'Constants::DEFAULT_POLL_PAGE_LIMIT);


Im Adminbereich kommt dieser

Warnung: Use of undefined constant _MI_XOOPSPOLL_OVERVIEW assumed '_MI_XOOPSPOLL_OVERVIEW' (this will throw an Error in a future version of PHPin Datei /modules/xoopspoll/xoops_version.php Zeile 142
Warnung
: Use of undefined constant _MI_XOOPSPOLL_DISCLAIMER assumed '_MI_XOOPSPOLL_DISCLAIMER' (this will throw an Error in a future version of PHPin Datei /modules/xoopspoll/xoops_version.php Zeile 143
Warnung
: Use of undefined constant _MI_XOOPSPOLL_LICENSE assumed '_MI_XOOPSPOLL_LICENSE' (this will throw an Error in a future version of PHPin Datei /modules/xoopspoll/xoops_version.php Zeile 144
Warnung
: Use of undefined constant _MI_XOOPSPOLL_SUPPORT assumed '_MI_XOOPSPOLL_SUPPORT' (this will throw an Error in a future version of PHPin Datei /modules/xoopspoll/xoops_version.php Zeile 145
Fehler
Error: Class 'XoopsModules/Xoopspoll/Constants' not found in Datei /modules/xoopspoll/admin/main.php Zeile 73


Auf der Startseite kommt denn auch dieser Fehler

FehlerError: Class 'XoopsModules/Xoopspoll/Constants' not found in Datei /modules/xoopspoll/index.php Zeile 88


in beiden wieder die Konstante gegen eine 0 ersetzt (auch andere Zahlen probiert, geht es mit diesem Fehler weiter

FehlerError: Class 'XoopsModules/Xoopspoll/Poll' not found in Datei /kernel/object.php Zeile 1352


Ich hatte jetzt Deine verlinkte Version nochmal runter geladen, neu hochgeladen und installiert. Es bleibt bei dem Fehler. Es muss ja an Xoops liegen, was auf dem Server installiert ist.Hier habe ich, im Gegensatz zum localhost, direkt die 2.5.11 installiert, kein Update vom 2.5.10 gemacht. Kann es daran liegen?

Wo bei ich hier ja auch schon alle Dateien aus der Version des localhost ersetzt hatte.

Ich verstehe es einfach nicht, warum es lokal geht, und auf dem Server nicht


Goffy

Co-Administrator
Gepostet am:09.08.2020 07:58
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 643
Since: 14.10.2004
#6

Aw: Module unter Xoops 2.5.10

wann genau kommt eigentlich der Fehler?

Was führst du auf welcher Seite aus?
EDV = Epoche der Verzweiflung


Goffy

Co-Administrator
Gepostet am:08.08.2020 20:59
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 643
Since: 14.10.2004
#7

Aw: Module unter Xoops 2.5.10

du kannst vorübergehend mal versuchen, die Konstante durch die entsprechende Zahl zu ersetzen
$criteria->add(new Criteria('mail_status'0'=')); // email not previously sent


laufen die übrigen Module jetzt?
EDV = Epoche der Verzweiflung


Goffy

Co-Administrator
Gepostet am:08.08.2020 19:58
Goffy
Goffy Offline (Show more)
Co-Administrator
Posts: 643
Since: 14.10.2004
#8

Aw: Module unter Xoops 2.5.10

Hi

hab auf Github einen neuen Issue angelegt
EDV = Epoche der Verzweiflung


WDC

"myXOOPs"-Könner
Gepostet am:08.08.2020 09:55
WDC
WDC Offline (Show more)
"myXOOPs"-Könner
Posts: 518
Since: 27.06.2004
#9

Aw: Module unter Xoops 2.5.10

Ich habe jetzt auf dem Server alle relevanten Xoops Systemdateien mit der vom localhost überschrieben und xoopspoll komplett neu hochgeladen und installiert, das Ergebnis bleibt das selbe.

Diese Zeile wird moniert
$criteria->add(new Criteria('mail_status'Constants::POLL_NOT_MAILED'=')); // email not previously sent


WDC

"myXOOPs"-Könner
Gepostet am:07.08.2020 15:49
WDC
WDC Offline (Show more)
"myXOOPs"-Könner
Posts: 518
Since: 27.06.2004
#10

Aw: Module unter Xoops 2.5.10

Ich habe die Module (xoopspoll und xoopspartner) beide wieder deinstalliert.

Bei beiden bekomme ich den selbern Fehler. Ich werde die Ordner dann mal mit WINSCP hochladen, evtl. gibt es damm Besserung. ich hatte die Ordner bisher mit Filezilla und dem WebFTP des Hosters hochgeladen.



TopTop
(1) 2 3 4 ... 4681 »